[nycbug-talk] su -

Kevin Reiter tux
Fri Nov 25 19:10:30 EST 2005

michael wrote:
> On a fresh FreeBSD 6.0 install (w/ xorg), I added my local user to
> wheel.  From another box, I can ssh to the local user then su to root.
> I can log into the console as the local user and su to root... but when
> running xorg as a local user, I can NOT su to root in xterm. I turned
> on pam warnings, but still no clue.  I've google around and can find the
> problem answered.  Any ideas?
> I don't normally log in as root.  During the first few days of software
> installation and configuration, it is just easier.

Just OOC, which shell are you using, or have you tried it using more than one 
shell with the same results?  I ask because I just finished a 6.0 install on my 
new laptop and was working on it for about 16 hours straight, doing everything you 
mentioned, without a hitch.  The only thing I do once I reboot after the install 
is install my bash files [1] and haven't had any problems since.

Does anything stand out in /var/log/messages or /var/log/auth?

Can't think of anything else ATM, but I'm due for my hourly caffeine injection, 
which might explain it..


[1] http://penguinnetwerx.net/bsd/bash_files.tar.gz

It said "use Linux 2.4 kernel or better" so I installed FreeBSD.  Now everything 
runs better.  Why didn't they just tell me to do that to begin with?

More information about the talk mailing list