<div>Just guessing, but can they use rsync to make the remote/sandbox machine into a copy of their production machine?¬† Also, I think ZFS had a means of sending file systems over IP block-by-block.¬† I don't know if either of these approaches helps them get when they need to go, but I thought I'd point them out and someone more knowledgeable might be able to do something useful with these ideas.</div><div><br></div><div>Jaime</div><div><br></div><div><br><div class="gmail_quote"><div>On Tue, Apr 18, 2017 at 11:30 AM Fongaboo <<a href="mailto:freebsd@fongaboo.com">freebsd@fongaboo.com</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><br>
Hello CapDist FreeBSD friends... I thought I might share this with you to<br>
see if anyone has any knowledge they can share...<br>
<br>
<a href="https://www.reddit.com/r/freebsd/comments/663idb/trying_to_recreate_a_102_machine/" rel="noreferrer" target="_blank">https://www.reddit.com/r/freebsd/comments/663idb/trying_to_recreate_a_102_machine/</a><br>
<br>
> Trying to recreate a 10.2 machine? (self.freebsd)<br>
><br>
> submitted 3 minutes ago by fongaboo<br>
><br>
> I have a production machine running 10.2. When we last attempted freebsdupdate and pkg update, a bunch of software we had installed broke. We were able to roll things back with a ZFS snapshot thank god.<br>
><br>
> We've since been given some steps to take with our particular software that will allow us to otherwise upgrade things. But I still don't want to try it first on the production machine. So I've created an Amazon EC2 instance with a 10.2 AMI, and am attempting to install everything the same as we have on the production machine, best I can... So that I can then attempt the upgrade in this safe space first.<br>
><br>
> Problem is, even though I've installed FreeBSD 10.2 on this instance, it seems to be using newer ports in the ports collection. For this to be an effective endeavor, I really need to install the versions of the software¬† that would have installed in 2015/2016. Dependencies are failing when I try to make install, so it's an actual problem.<br>
><br>
> When I first launched the instance, I ran portsnap fetch/update. Is there some way I could either roll back to a snapshot and run portsnap again with a modifier to get circa 2015 ports collection? Or could I somehow individually modify the make command to get the versions of software packages that match the production machine?<br>
><br>
> I've tried portdowngrade but it doesn't seem to have the correct versions of some of the ports that are being problematic.<br>
<br>
P.S. The software combo involved is pretty much FAMP, as described here: <a href="http://www.purplehat.org/?page_id=4" rel="noreferrer" target="_blank">http://www.purplehat.org/?page_id=4</a><br>
<br>
<br>
TIA<br>
<br>
_______________________________________________<br>
CDBUG-talk mailing list<br>
<a href="mailto:CDBUG-talk@lists.nycbug.org" target="_blank">CDBUG-talk@lists.nycbug.org</a><br>
<a href="http://lists.nycbug.org/mailman/listinfo/cdbug-talk" rel="noreferrer" target="_blank">http://lists.nycbug.org/mailman/listinfo/cdbug-talk</a><br>
</blockquote></div></div>