[Tor-BSD] Having issues forcing Tor release to build with update libssl.so.32.0 library

teor teor2345 at gmail.com
Sat Jul 4 03:06:48 EDT 2015

> On 2 Jul 2015, at 18:00 , Seth <list at sysfu.com> wrote:
> On Wed, 01 Jul 2015 23:28:29 -0700, teor <teor2345 at gmail.com> wrote:
>> The verbose output is on stderr, but your log only shows stdout.
> Sorry about that.

No worries. I only worked it out myself just before I sent the last email. I am using a GUI terminal, so there's no way to tell the difference when I copy output.

>> Can you please re-run:
>> make check <redirect stderr to stdout> | tee verbose-make-output.log
>> Each shell does stderr to stdout redirection slightly differently, so you might need to lookup the pdksh syntax.
> This time I ran:
> $ sudo make clean
> $ ./configure --with-openssl-dir=/usr/local --disable-asciidoc CC="/usr/bin/gcc -v"
> $ make check 2>&1 | tee verbose-make-output.log
> Please see attached log.<verbose-make-output.log>

These are the relevant log lines:

  CCLD     src/or/tor
Reading specs from /usr/lib/gcc-lib/amd64-unknown-openbsd5.7/4.2.1/specs
Target: amd64-unknown-openbsd5.7
Configured with: OpenBSD/amd64 system compiler
Thread model: posix
gcc version 4.2.1 20070719
 /usr/lib/gcc-lib/amd64-unknown-openbsd5.7/4.2.1/collect2 --eh-frame-hdr -Bdynamic -export-dynamic -dynamic-linker /usr/libexec/ld.so -pie -o src/or/tor /usr/lib/crt0.o /usr/lib/crtbegin.o -L/usr/local/lib -L/usr/lib/gcc-lib/amd64-unknown-openbsd5.7/4.2.1 src/or/tor_main.o src/or/libtor.a src/common/libor.a src/common/libor-crypto.a src/common/libcurve25519_donna.a src/ext/ed25519/ref10/libed25519_ref10.a src/common/libor-event.a src/trunnel/libor-trunnel.a -lz -lm -levent -lssl -lcrypto -lpthread -lgcc -lc -lgcc /usr/lib/crtend.o

The linker command is correct, and the relevant options are:
 -L/usr/local/lib -L/usr/lib/gcc-lib/amd64-unknown-openbsd5.7/4.2.1 … -lssl -lcrypto

I can't see anything wrong with the tor build process.
I wonder if there is a problem with your OpenBSD or LibreSSL install.

Does /usr/lib/gcc-lib/amd64-unknown-openbsd5.7/4.2.1 point to /usr/lib?
(I don't expect it to, but if it does, that's your issue.)

Otherwise, I can only assume your /usr/local/lib/libssl* is either:
* the wrong architecture,
* unreadable,
* loaded after /usr/lib/libssl*, or
* somehow excluded from your list of shared libraries (I don't know how OpenBSD configures shared libraries).

Can you build something else against the LibreSSL in /usr/local and get it to link correctly?

What is your libevent linked against?
Tor links against libevent, and libevent could be pulling in the SSL library from /usr/lib, before the ssl library from /usr/local/lib, but this is a longshot. (I don't know how conflicting libraries are resolved on OpenBSD.)

I can't really help beyond this point, as it looks like your issue is with OpenBSD shared libraries, and I don't have a test system or the relevant expertise.

Perhaps someone else can suggest how to debug a shared library link/load order issue?


Tim Wilson-Brown (teor)

teor2345 at gmail dot com

teor at blah dot im
OTR D5BE4EC2 255D7585 F3874930 DB130265 7C9EBBC7

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 832 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <http://lists.nycbug.org/pipermail/tor-bsd/attachments/20150704/57e49cae/attachment.bin>

More information about the Tor-BSD mailing list