[Tor-BSD] kernel: ... was killed: out of swap space

George Rosamond george at ceetonetechnology.com
Wed Feb 21 10:44:00 EST 2018


> Thanks to all your input first! You may laugh or cry, at worst think
> its a waste of time - for me its kind of "what can I get for smallest
> amount of invested money" This experiment worked well on several
> exits for over a year now - with different success depending on ISP
> and location - starting to turn sour with DDos attacks last year. It
> is strange that one small Exit doesn’t get affected by those attacks
> at one place running average 25Mbit/s while hardly doing 5 Mbit/s at
> an other and breaking every single day.
> So the facts:
> VPS RAM: 512MB FreeBSD 11.1-RELEASE-p4 on GENERIC  amd64 Running 2
> instances of Tor
> I did "CellStatistics off" a few days ago - little help 
> MaxMemInQueues always at default 324 MB
> I will follow now George in doing cron reboots every maybe 10 to 15
> hours.

rather, tor restarts.. not reboots.  And to be clear, it was an
embarrassing 'fix' as I tweaked OS-level mitigations.

> Furthermore I tried to install tor- from ports which
> stopped unfortunately here: " asciidoc-8.6.10_1 depends on shared
> library: libxml2.so - not found"
> What should I do there - please keep in mind I am not a coder :-(

My brain is in OpenBSD ports/packages at the moment, but you're
installing from FreeBSD ports?

Remove the currently installed version of security/tor first.

Make sure the ports tree is updated, and that textproc/libxml2 is
installed if that's what it's barking about.

And note the announce that the new stable Tor release is coming this week.


More information about the Tor-BSD mailing list