[CDBUG-talk] NetBSD 2.0 Mac68k

Jonathan Franks jonathan.franks at gmail.com
Wed Apr 6 17:50:42 EDT 2005

Hey all,

I've been working on loading NetBSD 2.0 on an old Quadra 800 that I
had laying around collecting dust. This is basically a "because I can"
project, so it's not at all urgent, but I keep running in to the same
snag and I'm wondering if any of you might have some advice.....

Essentially, what I would like to end up with is a machine that has
only NetBSD on the HDD. I've been trying to use the sysinst method to
install because I am unable to partition the drive using the
traditional method, given that it's the "startup disk".

So anyhow, everything works as expected until the installation begins.
After the new partitions are written to the drive, the installer
attempts /sbin/fsck_ffs -p -q /rsd0a and this fails unable to find
superblock. I've tried manually running fsck_ffs from the shell
available in the utilities menu of the installer, but I get exactly
the same results.

The MacOS is wiped out in the process, so in order to try again I have
to reinstall OS 8 and then try again. I've heard it said that one
definition of insanity is doing the same thing over and over expecting
different results, and thus, to avoid insanity (if indeed I am not
already too late) I've decided to stop for now and see if I can find
some further info.

One thing that I have not yet tried, but am planning to do, is to
install the MacOS to a small 100 MB partiton on the drive and then
simply use the rest for the install. It's not exactly what I want, but
if it works I suppose I can live with it.

So.... any ideas?

Also, if anyone has an unused AAUI to RJ45 adapter they'd like to sell
cheap, I'm willing to buy it....



More information about the CDBUG-talk mailing list