[CDBUG-talk] OpenBSD vs. Grub

Steve Moon steve.moon at gmail.com
Wed Nov 12 14:00:49 EST 2014

So I've got a dual-boot Linux/Windows laptop, with a spare 80GB partition.

I figured I'd fire up my spiffy new OpenBSD CD set and install it there,
which appeared to go great.

Grub is the bootloader. The OpenBSD partition is set to active, type A6,
and I let the OpenBSD installer divvy it up automatically.

In grub I edited the /etc/grub.d/40* file and added an entry for OpenBSD,
run update-grub, and rebooted.

As expected I got my nifty new OpenBSD boot option, but when I pick it I
get a "file not found" error from grub. I have done extensive googling and
manpage spelunking to no effect. I've tried a number of variations on how I
specify the partition (disk 0, partition 4).

I then tried to use uuid instead of disk/partition numbering, but running
blkid yields a list of partitions counting all of the openbsd ones -- so
instead of just seeing the 4 physical partitions I see something like 12,
and no uuid for the openbsd partition. Specifying a higher-than-4 partition
number just results in grub complaining about not finding the partition.

I don't want to get too agressive since I occasionally need to use Windows
and my Linux setup has a lot of customizations I was hoping to imitate in

Any ideas? I'm wondering if it is a 1st 1024 cylinder thing, since I'm in
the last 80GB of a 256GB SSD drive. But it seems like I'd then get an
openbsd error rather than a grub error.

The linux is Mint 14, grub is v2.0000xxxx, and yes I know grub v1 numbers
partitions from 0 while grub v2 numbers from 1 (seems like they could have
either figured that out to begin with, or just left it the same...

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.nycbug.org/pipermail/cdbug-talk/attachments/20141112/2f067a4f/attachment.html>

More information about the CDBUG-talk mailing list