[CDBUG-talk] Recreating a 10.2 machine

Fongaboo freebsd at fongaboo.com
Tue Apr 18 11:30:05 EDT 2017

Hello CapDist FreeBSD friends... I thought I might share this with you to 
see if anyone has any knowledge they can share...


> Trying to recreate a 10.2 machine? (self.freebsd)
> submitted 3 minutes ago by fongaboo
> I have a production machine running 10.2. When we last attempted freebsdupdate and pkg update, a bunch of software we had installed broke. We were able to roll things back with a ZFS snapshot thank god.
> We've since been given some steps to take with our particular software that will allow us to otherwise upgrade things. But I still don't want to try it first on the production machine. So I've created an Amazon EC2 instance with a 10.2 AMI, and am attempting to install everything the same as we have on the production machine, best I can... So that I can then attempt the upgrade in this safe space first.
> Problem is, even though I've installed FreeBSD 10.2 on this instance, it seems to be using newer ports in the ports collection. For this to be an effective endeavor, I really need to install the versions of the software  that would have installed in 2015/2016. Dependencies are failing when I try to make install, so it's an actual problem.
> When I first launched the instance, I ran portsnap fetch/update. Is there some way I could either roll back to a snapshot and run portsnap again with a modifier to get circa 2015 ports collection? Or could I somehow individually modify the make command to get the versions of software packages that match the production machine?
> I've tried portdowngrade but it doesn't seem to have the correct versions of some of the ports that are being problematic.

P.S. The software combo involved is pretty much FAMP, as described here: http://www.purplehat.org/?page_id=4


More information about the CDBUG-talk mailing list