[nycbug-talk] |OBSD Problem| - DHCP (network card) 'no DHCPOFFERS received'

G T unixenigma
Tue Nov 23 21:20:44 EST 2004

|OBSD Problem| - DHCP (network card) 'no DHCPOFFERS received'
Just wanted to share some troubleshooting i got myself into, plus maybe get some advice of what could've been done to resolve it...

Anyway, we bought 3 DELL 8200 systems about 2 years ago. So, decided it is time to switch and installed OBSD on one of them (mine). All went well; however, Ethernet card dc0 could not work properly.  By doing 'ifconfig -a' I can see all is in order. I can see if no carrier or active states. 
But, when I do dhclient dc0, I get 'no DHCPOFFERS received' and some other stuff. I tried resetting whatever i could, plus tried setting static ip - no luck! Went trough routing tables, pf is disabled, tried configured manually through ifconfig. Just for the record I have 2 more machines running OBSD with no network problems. Machines are connected to switch, all ips are public through DHCP. 
Anyway, I went through millions sites, got pissed and opened up my comp to change pci (thought changing bus would help). I saw no brand name card. So I opened up other 2 boxes - all cards are different (though shipped at the same time) - stupid DELL! Anyway from 3 cards I found one made by 3com - put it in - 100% working! The other 2 no name crap cards :) - left them for windows. I can reinstall the card to get dmesg if someone is interested... 
Is anybody had problem like that before? I tried all I could find on forums - setting up was OK, just card still was not working. I guess drivers were not compatible to these no-name-crap cards. I am a noob - big time. Probably I missed something. Just wanted to have your opinion on the subject as well as to help others who may encounter same problem... Is there another way (that doesn't involve programming new drivers) or just 'try another card' way? In any case I'm sorry for wasting your time.

p.s. if I'm not gonna be kicked from the list for long annoying question :) (tried to be descriptive) I will post a challenging question that was hunting me for some time...
Thanks peeps, chill! :)
|OBSD Problem| - DHCP (network card) 'no DHCPOFFERS received'

Do you Yahoo!?
 The all-new My Yahoo! ? What will yours do?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.nycbug.org/pipermail/talk/attachments/20041123/58d7d67f/attachment.html 

More information about the talk mailing list