[nycbug-talk] |OBSD Problem| - DHCP (network card) 'no DHCPOFFERS received'

Okan Demirmen okan
Wed Nov 24 00:03:16 EST 2004

On Tue 2004.11.23 at 19:56 -0800, pete at nomadlogic.org wrote:
> > ---------------------------------------------------------------------------------------------------
> > |OBSD Problem| - DHCP (network card) 'no DHCPOFFERS received'
> > ---------------------------------------------------------------------------------------------------
> >
> > Hello,
> > Just wanted to share some troubleshooting i got myself into, plus maybe
> > get some advice of what could've been done to resolve it...
> >
> > Anyway, we bought 3 DELL 8200 systems about 2 years ago. So, decided it is
> > time to switch and installed OBSD on one of them (mine). All went well;
> > however, Ethernet card dc0 could not work properly.  By doing 'ifconfig
> > -a' I can see all is in order. I can see if no carrier or active states.
> > But, when I do dhclient dc0, I get 'no DHCPOFFERS received' and some other
> > stuff. I tried resetting whatever i could, plus tried setting static ip -
> > no luck! Went trough routing tables, pf is disabled, tried configured
> > manually through ifconfig. Just for the record I have 2 more machines
> > running OBSD with no network problems. Machines are connected to switch,
> > all ips are public through DHCP.
> > Anyway, I went through millions sites, got pissed and opened up my comp to
> > change pci (thought changing bus would help). I saw no brand name card. So
> > I opened up other 2 boxes - all cards are different (though shipped at the
> > same time) - stupid DELL! Anyway from 3 cards I found one made by 3com -
> > put it in - 100% working! The other 2 no name crap cards :) - left them
> > for windows. I can reinstall the card to get dmesg if someone is
> > interested...
> > Is anybody had problem like that before? I tried all I could find on
> > forums - setting up was OK, just card still was not working. I guess
> > drivers were not compatible to these no-name-crap cards. I am a noob - big
> > time. Probably I missed something. Just wanted to have your opinion on the
> > subject as well as to help others who may encounter same problem... Is
> > there another way (that doesn't involve programming new drivers) or just
> > 'try another card' way? In any case I'm sorry for wasting your time.
> when you are trying to trouble shoot problems with specific hardware
> configurations it is generally helpfull to post a dmesg of your running
> system to the list.  you can just type "dmesg" in a shell and paste the
> results into your email.  it does sound like either your cards are broken
> or have a chipset on them that is not supported by OpenBSD.

i would double-check the no name brand thing on the cards. look for
the actual chipset instead of the manufacturer. might help identify
the card physically. but i agree with pete, dmesg's help ;)

that being said, i once had a very odd issue with dc(4). i had ONE
physical DEC card in a random x86 box, but the system swore up and down
that it had two. i never figured it out - though, that was a few years
ago now, so who knows....


> -pete
> ~~~oO00Oo~~~
> Pete Wright
> email:  pete at nomadlogic.org
> mobile: 917.415.9866
> web:    www.nomadlogic.org/~pete
> _______________________________________________
> % NYC*BUG talk mailing list
> http://lists.nycbug.org/mailman/listinfo/talk
> %Be sure to check out our Jobs and NYCBUG-announce lists
> %We meet the first Wednesday of the month

Okan Demirmen <okan at demirmen.com>
PGP-Key: http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xB3670934
PGP-Fingerprint: 226D B4AE 78A9 7F4E CD2B 1B44 C281 AF18 B367 0934

More information about the talk mailing list