[nycbug-talk] 5.2.1 => 5.3 upgrade

Scott Robbins scottro
Sun Sep 26 17:33:50 EDT 2004

Hash: SHA1

Well, with 5.3 nearing RELEASE status, thought I'd try a few test

The first one knocked out X.  On BSD forums, I was told that I'd
probably have to recompile almost all ports.  This sounded like a
nuisance, to say the least, so I let it lay for a bit.

Then, last night, I got an attack of ambition. We already have several
boxes at work running 5.2.1 (all non-critical, I might add) and I
thought I should see exactly what problems I might have.  Also, I'm
getting close to wanting to upgrade my two main workstations, (one at
home, one at work) and figured I might as well see how bad it was going
to be.)

So, I took a test box here and installed 5.2.1 as I usually do, the bare
minimum installation, then do a cvsup, buildworld, kernel, etc. 

I installed the packages that I consider minimal for a workstation, as
well as two that I use on all the servers at work (cups and samba).  I
installed X, fluxbox-devel, mutt-devel, ssmtp (none of these are mail
servers and I just want an smtp program to send reports) getmail,
ja-wm3-img, things like sudo, screen and portupgrade, etc.  I also
installed Openoffice-1.1-devel which I use on the two main workstations,
to see how much trouble that would be.

After changing the supfile to RELENG 5 and doing world and kernel,
almost everything worked.  X didn't.  So I did portupgrade -rRn to see
what it felt it needed, and it said that xorg-server should be upgraded.
Did that.  Now X would start in twm but not fluxbox.  Portupgrade said I
didn't have to upgrade it, so I did make deinstall, make reinstall to
see what would happen.  Now, fluxbox worked, but bsetbg gave problems.
Deinstalled and reinstalled boxtools, which provides the bsetbg command
and then everything was fine. 

OpenOffice, opera and rxvt, the only X programs that I added at present,
all worked without problem.  I don't run KDE or Gnome, I have no idea
what will happen to folks who run those.  

So, I'm getting up my nerve to do it on my two main workstations
next--already did it remotely on the least important server remotely
without problem.  I'm less worried about them, in a way, as cups and
samba both seem to work.

So, thought I'd pass this on in case it interested anyone.

- --

PGP keyID EB3467D6
( 1B48 077D 66F6 9DB0 FDC2 A409 FA54 D575 EB34 67D6 )
gpg --keyserver pgp.mit.edu --recv-keys EB3467D6

Wesley: The Council's orders are to concentrate on the...
Buffy: Orders. I don't think I'm going to be taking any more 
orders. Not from you, not from them. 
Wesley: You can't turn your back on the Council. 
Buffy: They're in England. I don't think they can tell which way 
my back is facing. 
Version: GnuPG v1.2.6 (FreeBSD)


More information about the talk mailing list