[nycbug-talk] Rescuing an OpenBSD 3.0 System

Jim Brown jpb
Fri Aug 5 16:10:26 EDT 2005

* Jonathan Vanasco <jvanasco at mastersofbranding.com> [2005-08-05 15:44]:
> We had a power flicker last week that seemed to have knocked out one  
> of our UPS regulators and everything on it.
> I thought everything was moved over and happy on a new regulator  
> until i walked into the office this morning -- our firewall was in a  
> constant reboot cycle.
> It's an eracks.com box w/ a ecs p6stmt rev 1.0 motherboard, running  
> openbsd 3.0
> It does one of two things:
>   boots about 20seconds into openbsd, then reboots
>   boots about 5 seconds into bios, then reboots
> I tried booting off a cd.  if it doesn't reboot automagically, it  
> does when i issue a command on the shell.
> I swapped in the one bar of like memory i could find -- no luck
> I plugged/unplugged every card in the box -- no luck
> I'm guessing the bios got screwed by a power surge (although that  
> doesn't explain why it started rebooting overnight - it was fine last  
> night)
> I'm at a loss of what to do - i tried tossing the drives into the  
> other boxes i have in the office, but then i get
>     ===
>     Using Drive: 0 Partition: 3
>     reading boot...
>     Bad magic
>     ===
> Which google says is something that I really don't want to see.
> barring a miracle, i need to get a new firewall
> the downed machine has all of the local networking stuff -- firewall,  
> lan, proxy stuff -- which i need to get off -- we never backed it up,  
> and there's too much to rewrite
> does anyone have a suggestion to make my week less of a nightmare?

Sounds like a bad disklabel.  

Sit down and breath slowly.  

When you are OK, go find a copy of scan_ffs - a disklabel recovery tool, written
by some OpenBSD guys.  My candidate for the BEST BUTTSAVER award.

You may need to transfer the disk to a working system to use it.  It might
also be on a rescue CD or live-CD.  Check around.

I was able to use this tool to recover my FreeBSD disklabel even after I had tried
recreating it by hand - a mistake as it turned out.

Hope this helps,
Jim B.

More information about the talk mailing list