[nycbug-talk] CUPS-1.2 on CURRENT

Scott Robbins scottro at nyc.rr.com
Mon Jun 26 19:46:43 EDT 2006

I'm wondering if anyone has upgraded to CUPS-1.2 on CURRENT. 

I've run into a variety of problems--one having to do with my wife being
unable to print from her Mac so I had to downgrade quickly. 

Problem one is covered in PR99460, and seems to be general, regardless
of O/S.  (Not my PR).  Someone found that when printing to an attached
USB printer, he got permission denied.  A workaround, covered in the
PR, was to change permissions and ownership on the device. This worked
for me as well with /dev/lpt0. 

Secondly, and possibly worth a PR, is that the web interface doesn't
offer the option of a parallel or USB connection.  I use lpadmin (which
was another problem--I could be wrong about this, but I think the new
version doesn't install the old manual, which goes through an
explanation of lpadmin.)  Someone not experienced with CUPS would
probably be at a loss, especially as their (cups.org) web site says a
locally attached USB or parallel printer will show up on the web
interface.   I haven't had a chance to play with this at all at work,
but I believe it had the same issue--on a 6.1-STABLE box, only networked
options (ipp, JetDirect, http and lpd) were offered. 

Printing with samba also seems to have a problem in CURRENT.  On the
STABLE box at work, I didn't run into this problem (though I didn't have
the nerve to upgrade anything but a test box.)  However, on my box at
home, when I tried printing on an MS box through samba, despite having
uncommented the octet-stream lines mime.types and mime.convs, I got the
error that application/octet-stream wasn't supported.  

This was a cups bug at one point, (see their site,
www.cups.org/str.php?L1667) but is apparently fixed, and seems to be so
in STABLE.  There is a workaround mentioned before it was fixed, to add

cups options = raw 

to smb.conf, but I didn't stop to try that as the important thing was
enabling the Mac to print.  

As I said the showstopper for me was the Mac, which doesn't print
through samba.  I was getting errors like

No %%BoundingBox: comment in header.
No %%Pages: comment in header.

At that point, fearing an explosion at home, rather than trying to
troubleshoot, I chose discretion as the better part of valor and
downgraded.  I can't test this with the Macs at work either, as they're
all production machines and I don't want to get daring.  :)

So, I'm wondering if anyone else has run into any of this.  The only one
that I'm considering filing a PR on is the one of the parallel and USB
devices missing from the web interface, as I can examine that one at
leisure on the testbox at work.

No real questions here, just asking what experiences anyone else has had
upgrading to cups-1.2 on FreeBSD.  Had I not run into all these problems
on the home machine, I wouldn't even have realized they existed--on the
work machine, the upgrade was smooth, but that prints to networked
printers and only (rarely) serves one MS machine.


Scott Robbins

PGP keyID EB3467D6
( 1B48 077D 66F6 9DB0 FDC2 A409 FA54 EB34 67D6 )
gpg --keyserver pgp.mit.edu --recv-keys EB3467D6

Cordelia: I came over here to tell Buffy to stop this
craziness, and 
found you all unconscious--again. How many times have you been
knocked out, anyway? I swear, one of these times, you're going
to wake up in a coma.
Giles: Wake up in a...? Oh, never mind. We need to save Buffy from 
Hansel and Gretel.
Cordelia: Now, let's be clear. The brain damage happened before I hit

More information about the talk mailing list