[nycbug-talk] NetBSD, Apache and mod_python problems

Ivan "Rambius" Ivanov rambiusparkisanius at gmail.com
Thu Feb 15 15:10:29 EST 2007


I have a machine running NetBSD 3.1 with Apache Httpd 2.2.3 installed
from pkgsrc. Yesterday I tried to install mod_python from ap2-python
pkgsrc package and it compiled and installed successfully.

However, when I tried to load mod_python module, apache refused to
start. The following error is dumped to /var/log/httpd/error_log:

[Thu Feb 15 03:11:14 2007] [emerg] (28)No space left on device:
Couldn't create accept lock (/usr/pkg/var/accept.lock.524) (5)

First, I did check if I have empty space:

$ df -h
Filesystem    Size      Used     Avail Capacity  Mounted on
/dev/wd0a     8.0G     983M      6.7G    12%    /
/dev/wd0e     7.7G     230K      7.3G     0%    /home
kernfs        1.0K     1.0K        0B   100%    /kern

Next, I verified that the apache user and group had write permissions
to /usr/pkg/var directory

$ ls -al /usr/pkg/
drwxrwx---   2 www   www     512 Jan 28 03:14 var

Finally, I googled around and I found some references that apache is
unable to create semaphores[1]. I stared "ipcs -s" command, but there
are no semaphores.

Could you please help me with using mod_python on NetBSD?



Tangra Mega Rock: http://www.radiotangra.com

More information about the talk mailing list