[talk] scp umask headbanging

Isaac (.ike) Levy ike at blackskyresearch.net
Mon Oct 5 15:42:33 EDT 2015

Hi All,

I've got a stupid "I'm stumped" question, haven't hit my head on this in a *long* time:

I've got a directory on a FreeBSD box which is shared by many users, lets say it's:


chmod 2775 /usr/local/www/something
chown root:wheel /usr/local/www/something

Also, in login.conf, default umask is 002, that's working fine.

So, for SFTP use, and general shell access to write/modify files, means that all files get default ownership perms of:
- dirs:  775
- files: 664

Just what I wanted.  Working acceptably for rsync, whereby I get 644 not 664 for files, but whatever.

Now, scp.  The outlier.

When I scp files to the dir, they end up 700 and 600, respectively.  I've worked around it from every angle imaginable, to no avail, just banging my head.  sshd_config tweaks, -u to sftp-server (nope), even tried lighting PAM bits- to no avail.

Anyone have any thoughts?

Other bits:
FreeBSD 10.2, OpenSSH_6.6.1p1


More information about the talk mailing list