[nycbug-talk] NYCBUG dmesg database partly broken

Fabian Keil freebsd-listen
Wed Mar 8 10:04:57 EST 2006

I failed several times to guess the contact form's pass phrase right,
therefore I'm trying my luck here.

About a month ago I submitted FreeBSD's dmesg output on a
ThinkPad R51, a few weeks ago Anonym.OS's dmesg output
on the same system.

When I tried to get the first dmesg output to copy the
ThinkPad version string (UN0K6GE) I noticed that dmesgd
displays the wrong dmesg output:

The dmesg output begins with:
"Copyright (c) 1992-2005 The FreeBSD Project.where dmesgid=1026;"

Interestingly dmesgid 1026 doesn't appear on the dmesg list at all,
there is a gap between dmesgid 1027 and dmesgid 1024.

I didn't verify it, but it looks as if all queries for dmesgids
below 1028 get the same result.

Another problem is that the website injects broken HTML
into the dmesg output:

ACPI APIC Table: <a m="" i="" oemapic="">
ioapic0 <version 1.1=""> irqs 0-23 on motherboard
npx0: [FAST]
npx0: <math processor=""> on motherboard
npx0: INT 16 interface
acpi0: </math></version></a><a m="" i="" oemxsdt=""> on motherboard
acpi0: Power Button (fixed)

"<" characters often aren't escaped and even if valid HTML doesn't seem
to be of any concern
this leads to missing information as the browser treats parts of
the output as unknown HTML tags which aren't displayed.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.nycbug.org/pipermail/talk/attachments/20060308/d44e3b30/attachment-0001.bin 

More information about the talk mailing list